Some questions about LiquidBounce - cross_version



  • I got LiquidBounce - cross_version source, I think to import the 1.12.2 version, it defaults to 1.8.9, how can I import 1.12.2 source?



  • Compile the 1.12 folder ?



  • @Leejames2305 Compile the bounce 1.12.2 liquid source



  • @Leejames2305 Do you have any tutorial?



  • @NUMB said in Some questions about LiquidBounce - cross_version:

    tutorial

    It isn't open-source yet



  • @NUMB
    Actually u can,
    The first step to do is to checkout the cross_version branch. (Default master branch does not contains any cross_version stuff yet)
    just cd to the root dir of LB and git checkout cross_version. If u use your fork, you should know how to add a remote for it and how to use.
    Look into the setting.gradle and you will see

    rootProject.name = 'LiquidBounce'
    
    if (System.getenv()['mcversion'] == "1.12") {
        include '1.12.2-Forge'
    } else {
        include '1.8.9-Forge'
    }
    
    // include '1.8.9-Vanilla'
    

    Which means you only have to make the environment variable mcversion equals to 1.12 then you can do gradlew build.
    On *nix u need to use mcversion="1.12" bash ./gradlew build, I already forgot how to temporarily set a environment variable on Windows.
    d2bc7f46-ac0c-47c2-8492-6ae417763a74-image.png

    The jar will be at 1.12.2-Forge/build/libs/LiquidBounce-B73.jar

    However I have not found a way to change environment variable in Intellij idea, because simple modifying setting.gradle takes less energy(still bad tho).

    Btw last time when I compiled cross_version stuff I had to modify one import statment to compile, never tested tho(it was at this commit). There seemed to be more frequent commits lately, it might be ready to use in a short period I guess. (Spoiler: there is a new branch for 1.16.2-fabric, however there is no commit yet)

    Edit: I tested and crashed when I tired to launch lol.
    Edit: Crashing in splash screen does not always happens. I managed to launch once



  • @commandblock2 Thank you very much
    :)



  • @commandblock2 said in Some questions about LiquidBounce - cross_version:

    gradlew build

    Hello, I have completed gradlew build according to your tutorial, and there is no problem displayed on my IntelliJ idea. When I tried to run the source code of 1.12.2-forge, my IntelliJ idea made a mistake in the build source code. I collected the wrong information, please see:Log.txt
    and
    Log(2).txt
    Can you help me to find out the reason and give the solutions? :)



  • @NUMB yeah, that was what I said about

    I had to modify one import statment

    It was because ofEasingObjectwas not here, you can search for it or see how 1.8.9-Forge did it.
    Edit: import net.ccbluex.liquidbounce.injection.utils.EasingObject; -> import net.ccbluex.liquidbounce.utils.render.EasingObject;.
    Edit: of the file net/ccbluex/liquidbounce/injection/forge/mixins/fml/MixinSplashProgressAC2.java
    No I still don't no why it crashes



  • @commandblock2 emmm, I think I have the same situation. When I run the 1.12.2 source, my idea runs to "at" java.lang.ClassLoader .loadClass( ClassLoader.java:351 ) ~[?:1.8.0_ 251] "when the source of 1.12.2 stopped running, I suspect it seems to crash, I did not find a solution to it, did you solve it?

    Crash: [16:00:40] [main / Info]: Extra: []

    [16:00:40] [main/ERROR]: Failed to find class net.minecraftforge.fml . common.asm.transformers .ModAccessTransformer

    [16:00:42] [main/INFO]: Running with arguments: [--userProperties, {}, --assetsDir, C:/Users/19077/.gradle/caches/minecraft/assets, --assetIndex, 1.12, --accessToken{REDACTED}, --version, 1.12.2, --tweakClass, net.minecraftforge.fml . common.launcher.FMLTweaker , --tweakClass, net.minecraftforge.gradle . tweakers.CoremodTweaker ]

    [16:00:42] [main/INFO]: Loading tweak class name net.minecraftforge.fml . common.launcher.FMLTweaker

    [16:00:42] [main/ERROR]: Unable to launch

    java at net.minecraft.launchwrapper . LaunchClassLoader.findClass ( LaunchClassLoader.java:106 ) ~[launchwrapper-1.12.jar:?]

    At java.lang.ClassLoader .loadClass( ClassLoader.java:418 ) ~[?:1.8.0_ 251]

    At java.lang.ClassLoader .loadClass( ClassLoader.java:351 ) ~[?:1.8.0_ 251]

    At java.lang.Class .forName0(Native Method) ~[?:1.8.0_ 251]

    At java.lang.Class .forName( Class.java:348 ) ~[?:1.8.0_ 251]

    At net.minecraft.launchwrapper . Launch.launch ( Launch.java:98 ) [launchwrapper-1.12.jar:?]

    At net.minecraft.launchwrapper . Launch.main ( Launch.java:28 ) [launchwrapper-1.12.jar:?]

    At sun.reflect.NativeMethodAccessorImpl .invoke0(Native Method) ~[?:1.8.0_ 251]

    At sun.reflect.NativeMethodAccessorImpl .invoke(Nati veMethodAccessorImpl.java:62 ) ~[?:1.8.0_ 251]

    At sun.reflect.DelegatingMethodAccessorImpl .invoke(Delegati ngMethodAccessorImpl.java:43 ) ~[?:1.8.0_ 251]

    At java.lang.reflect . Method.invoke ( Method.java:498 ) ~[?:1.8.0_ 251]

    At net.minecraftforge.gradle . GradleStartCommon.launch ( GradleStartCommon.java:97 ) [start/:?]

    At GradleStart.main ( GradleStart.java:25 ) [start/:?]. lang.ClassNotFoundException : net.minecraftforge.fml . common.launcher.FMLTweaker

    At java.net.URLClassLoader .findClass( URLClassLoader.java:382 ) ~[?:1.8.0_ 251]

    At java.lang.ClassLoader .loadClass( ClassLoader.java:418 ) ~[?:1.8.0_ 251]

    At sun.misc.Launcher $ AppClassLoader.loadClass ( Launcher.java:355 ) ~[?:1.8.0_ 251]

    At java.lang.ClassLoader .loadClass( ClassLoader.java:351 ) ~[?:1.8.0_ 251]

    Process finished with exit code 1



  • @NUMB No. It's still a dev version and it can sometime launch. Idk if it is my problem



  • @commandblock2 That is to say I IDE will start game?



  • @NUMB It will crash most times, but some times could launch, I didn't investigate anymore.



  • @commandblock2 I know that you have put a lot of energy into answering my question, but I have another question. I run in debug mode, and "disconnected from the target VM, address: '127.0.0.1:60563', Transport: 'socket' "error, and then quit running. I used the DOS command window to query the process of port" 60563 ", and found that no process occupied the port. This puzzled me. Can you help me?



  • @NUMB idk, I think I used to have this problem but now I don't seem to able to reproduce it. Maybe just try more times it might be fine


Log in to reply